Added include/linux/compat-4.5.h
[compat-rdma/compat.git] / include / linux / compat-4.5.h
1 #ifndef LINUX_4_5_COMPAT_H
2 #define LINUX_4_5_COMPAT_H
3
4 #include <linux/version.h>
5
6 #if (LINUX_VERSION_CODE < KERNEL_VERSION(4,5,0))
7
8 #include <linux/netdevice.h>
9
10 #ifndef NETIF_F_CSUM_MASK
11 #define NETIF_F_CSUM_MASK NETIF_F_ALL_CSUM
12 #endif
13
14 #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(4,5,0)) */
15
16 #endif /* LINUX_4_5_COMPAT_H */