~aditr/ofed_scripts.git
16 months agoinstall.pl: Disable compat-rdma-firmware on SLES12SP4 due to conflict master
Vladimir Sokolovsky [Tue, 19 Feb 2019 21:29:06 +0000 (15:29 -0600)]
install.pl: Disable compat-rdma-firmware on SLES12SP4 due to conflict

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
17 months agoinstall.pl: Added SLES12 SP4 support
Vladimir Sokolovsky [Thu, 7 Feb 2019 19:20:29 +0000 (21:20 +0200)]
install.pl: Added SLES12 SP4 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
17 months agoinstall.pl: Added RHEL7.6 support
Vladimir Sokolovsky [Thu, 7 Feb 2019 00:00:37 +0000 (18:00 -0600)]
install.pl: Added RHEL7.6 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
19 months agoinstall.pl: Added openssl-devel requirement for mstflint
Vladimir Sokolovsky [Fri, 7 Dec 2018 17:57:23 +0000 (11:57 -0600)]
install.pl: Added openssl-devel requirement for mstflint

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
19 months agoinstall.pl: Disable ncme support on RHEL7.x and SLES12SPx
Vladimir Sokolovsky [Thu, 6 Dec 2018 20:08:15 +0000 (14:08 -0600)]
install.pl: Disable ncme support on RHEL7.x and SLES12SPx

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
19 months agoinstall.pl: Update list of the in-box packages to be uninstalled
Vladimir Sokolovsky [Fri, 30 Nov 2018 16:12:06 +0000 (10:12 -0600)]
install.pl: Update list of the in-box packages to be uninstalled

Bug: https://bugs.openfabrics.org/show_bug.cgi?id=2692

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
19 months agoinstall.pl: Add RPM requirements for SLES
Vladimir Sokolovsky [Fri, 9 Nov 2018 20:06:52 +0000 (22:06 +0200)]
install.pl: Add RPM requirements for SLES

kernel-source and kernel-default-devel are required to build compat-rdma
RPM

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
21 months agoinstall.pl: Enable NVME target
Vladimir Sokolovsky [Tue, 18 Sep 2018 21:02:46 +0000 (16:02 -0500)]
install.pl: Enable NVME target

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
21 months agoinstall.pl: Enable qib for 4.17 kernel only
Vladimir Sokolovsky [Tue, 18 Sep 2018 21:00:31 +0000 (16:00 -0500)]
install.pl: Enable qib for 4.17 kernel only

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
21 months agoinstall.pl: Added isert support
Vladimir Sokolovsky [Wed, 12 Sep 2018 14:35:46 +0000 (09:35 -0500)]
install.pl: Added isert support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
22 months agoinstall.pl: Enable compat-rdma-firmware on all supported OSes
Vladimir Sokolovsky [Wed, 15 Aug 2018 18:25:25 +0000 (13:25 -0500)]
install.pl: Enable compat-rdma-firmware on all supported OSes

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
22 months agoinstall.pl: Enable nvme host support
Vladimir Sokolovsky [Fri, 10 Aug 2018 20:22:58 +0000 (16:22 -0400)]
install.pl: Enable nvme host support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
23 months agoinstall.pl: Disabled nes kernel module
Vladimir Sokolovsky [Tue, 7 Aug 2018 20:16:38 +0000 (15:16 -0500)]
install.pl: Disabled nes kernel module

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
23 months agoinstall.pl: Added SLES15 support
Vladimir Sokolovsky [Thu, 26 Jul 2018 21:08:38 +0000 (16:08 -0500)]
install.pl: Added SLES15 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: libibcm was removed from rdma-core
Vladimir Sokolovsky [Wed, 2 May 2018 18:22:45 +0000 (13:22 -0500)]
install.pl: libibcm was removed from rdma-core

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Fix check for existing NVME kernel modiles
Vladimir Sokolovsky [Wed, 2 May 2018 18:21:35 +0000 (13:21 -0500)]
install.pl: Fix check for existing NVME kernel modiles

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Disable compat-rdma-firmware on RHEL7.5 due to conflict with linux-firmware
Vladimir Sokolovsky [Wed, 2 May 2018 16:30:07 +0000 (11:30 -0500)]
install.pl: Disable compat-rdma-firmware on RHEL7.5 due to conflict with linux-firmware

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Updated list of supported OSes and kernels
Vladimir Sokolovsky [Wed, 2 May 2018 15:26:20 +0000 (10:26 -0500)]
install.pl: Updated list of supported OSes and kernels

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Ignore firmware in compat-rdma-content
Vladimir Sokolovsky [Mon, 5 Mar 2018 23:13:25 +0000 (17:13 -0600)]
install.pl: Ignore firmware in compat-rdma-content

firmware is included in compat-rdma-firmware RPM, so, it should be
ignored when examing the content of compat-rdma RPM.

bug: 2677

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoadd --with-rdmavt-mod for qib
Jay Sternberg [Tue, 6 Feb 2018 22:58:29 +0000 (14:58 -0800)]
add --with-rdmavt-mod for qib

2 years agoAdd VMware Paravirtual RDMA Driver as an installable driver
Adit Ranadive [Tue, 23 Jan 2018 01:34:34 +0000 (17:34 -0800)]
Add VMware Paravirtual RDMA Driver as an installable driver

Signed-off-by: Adit Ranadive <aditr@vmware.com>
2 years agoRemove vmw_pvrdma tech preview install option
Adit Ranadive [Fri, 19 Jan 2018 16:50:54 +0000 (08:50 -0800)]
Remove vmw_pvrdma tech preview install option

Signed-off-by: Adit Ranadive <aditr@vmware.com>
2 years agoinstall.pl: Added rdma-core-devel dependency for the perftest build
Vladimir Sokolovsky [Mon, 18 Dec 2017 19:41:06 +0000 (21:41 +0200)]
install.pl: Added rdma-core-devel dependency for the perftest build

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoRevert "install.pl: Enable bnxt_re on supported OSes only"
Vladimir Sokolovsky [Mon, 18 Dec 2017 17:07:52 +0000 (19:07 +0200)]
Revert "install.pl: Enable bnxt_re on supported OSes only"

This reverts commit 79e7f1da55f385a7eafa42ae8f8d2bc5b9645196.

2 years agoinstall.pl: Added compat-rdma-firmware package
Vladimir Sokolovsky [Mon, 18 Dec 2017 16:40:26 +0000 (18:40 +0200)]
install.pl: Added compat-rdma-firmware package

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Enable bnxt_re on supported OSes only
Vladimir Sokolovsky [Tue, 5 Dec 2017 22:32:26 +0000 (00:32 +0200)]
install.pl: Enable bnxt_re on supported OSes only

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Updated rdma-core dependencies
Vladimir Sokolovsky [Tue, 5 Dec 2017 20:53:19 +0000 (22:53 +0200)]
install.pl: Updated rdma-core dependencies

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Remove requirement on the specific cmake version
Vladimir Sokolovsky [Tue, 5 Dec 2017 20:00:43 +0000 (22:00 +0200)]
install.pl: Remove requirement on the specific cmake version

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Added support for SLES12 SP3
Vladimir Sokolovsky [Tue, 5 Dec 2017 16:23:20 +0000 (18:23 +0200)]
install.pl: Added support for SLES12 SP3

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Added RHEL7.4 support
Vladimir Sokolovsky [Mon, 4 Dec 2017 16:16:01 +0000 (18:16 +0200)]
install.pl: Added RHEL7.4 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoAdded support for rdma-core new packaging format
Vladimir Sokolovsky [Wed, 20 Sep 2017 17:05:09 +0000 (20:05 +0300)]
Added support for rdma-core new packaging format

Now rdma-core creates different binary RPMs per Distro
Some RPMs have loop dependencies so, added workaround for this.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Added support for using source RPM per Distro
Vladimir Sokolovsky [Tue, 19 Sep 2017 21:10:05 +0000 (00:10 +0300)]
install.pl: Added support for using source RPM per Distro

Starting rdma-core-v15 there are different RPM spec files per SUSE and RedHat.
So, install.pl will use the corresponding source RPM.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoinstall.pl: Enable nfsrdma on RHEL7.3 and SLES12 SP2
Vladimir Sokolovsky [Fri, 1 Sep 2017 21:56:58 +0000 (00:56 +0300)]
install.pl: Enable nfsrdma on RHEL7.3 and SLES12 SP2

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
2 years agoFix syntax error after libbnxt_re-rdmav2
Selvin Xavier [Wed, 23 Aug 2017 10:53:04 +0000 (06:53 -0400)]
Fix syntax error after libbnxt_re-rdmav2

Signed-off-by: Selvin Xavier <selvin.xavier@broadcom.com>
2 years agoAdd bnxt_re support
Selvin Xavier [Tue, 22 Aug 2017 18:14:38 +0000 (11:14 -0700)]
Add bnxt_re support

Signed-off-by: Selvin Xavier <selvin.xavier@broadcom.com>
2 years agoAdd qedr
Ram Amrani [Wed, 2 Aug 2017 09:27:58 +0000 (12:27 +0300)]
Add qedr

3 years agoRevert "install.pl: disable QIB driver on kernel 4.8"
Vladimir Sokolovsky [Thu, 8 Jun 2017 18:15:19 +0000 (21:15 +0300)]
Revert "install.pl: disable QIB driver on kernel 4.8"

This reverts commit 20adc3b412102392240b70f20a4a5717d40b2692.

3 years agoinstall.pl: disable QIB driver on kernel 4.8
Vladimir Sokolovsky [Thu, 1 Jun 2017 19:40:57 +0000 (22:40 +0300)]
install.pl: disable QIB driver on kernel 4.8

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Disable inband support for mstflint
Vladimir Sokolovsky [Thu, 25 May 2017 22:47:08 +0000 (01:47 +0300)]
install.pl: Disable inband support for mstflint

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoofed-scripts: Enable iwpmd for iWarp drivers
Tatyana Nikolova [Thu, 25 May 2017 04:54:48 +0000 (23:54 -0500)]
ofed-scripts: Enable iwpmd for iWarp drivers

Signed-off-by: Tatyana Nikolova <tatyana.e.nikolova@intel.com>
3 years agoinstall.pl: Set availability for qib module
Vladimir Sokolovsky [Fri, 5 May 2017 14:19:03 +0000 (17:19 +0300)]
install.pl: Set availability for qib module

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoMerge branch 'for-vlad' of git://git.openfabrics.org/~aditr/ofed_scripts
Vladimir Sokolovsky [Wed, 15 Mar 2017 21:48:42 +0000 (23:48 +0200)]
Merge branch 'for-vlad' of git://git.openfabrics.org/~aditr/ofed_scripts

3 years agoofed-scripts: Fixing the variable for NVMe-oF modules inclusion in kernel 4.8
rajlaxmi angadi [Wed, 15 Mar 2017 21:43:16 +0000 (23:43 +0200)]
ofed-scripts: Fixing the variable for NVMe-oF modules inclusion in kernel 4.8

Signed-off-by: rajlaxmi angadi <rajalaxmi.angadi@intel.com>
Signed-off-by: Jay Sternberg <jay.e.sternberg@intel.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoofed-scripts: Add i40iw to install script
Tatyana Nikolova [Wed, 15 Feb 2017 20:36:10 +0000 (14:36 -0600)]
ofed-scripts: Add i40iw to install script

Add new drivers i40iw and i40e to install script.
Enable their installation only on linux 4.8.

Signed-off-by: Tatyana Nikolova <tatyana.e.nikolova@intel.com>
3 years agoAdd support for VMware PVRDMA user driver
Adit Ranadive [Tue, 14 Mar 2017 17:52:05 +0000 (10:52 -0700)]
Add support for VMware PVRDMA user driver

Signed-off-by: Adit Ranadive <aditr@vmware.com>
3 years agoofed-scripts: Modified install.pl script to restrict NVMe-oF to 4.8 kernel
rajlaxmi angadi [Mon, 13 Mar 2017 21:33:45 +0000 (14:33 -0700)]
ofed-scripts: Modified install.pl script to restrict NVMe-oF to 4.8 kernel

NVMe-oF relies on modules only available in kernel 4.8 or greater,
so we are restricting it to 4.8 until backports are available.

Signed-off-by: Rajlaxmi Angadi <rajalaxmi.angadi@intel.com>
Signed-off-by: Jay Sternberg <jay.e.sternberg@intel.com>
3 years agoMerge branch 'master' of git://git.openfabrics.org/~jays/ofed_scripts
Vladimir Sokolovsky [Thu, 2 Mar 2017 13:08:39 +0000 (15:08 +0200)]
Merge branch 'master' of git://git.openfabrics.org/~jays/ofed_scripts

3 years agoinstall.pl: Uninstall Chelsio packages
Steve Wise [Tue, 21 Feb 2017 20:30:51 +0000 (12:30 -0800)]
install.pl: Uninstall Chelsio packages

Uninstall Chelsio Unified Wire rpms before installing OFED.

Signed-off-by: Steve Wise <swise@opengridcomputing.com>
3 years agoadd nvme to install.pl
Rajalaxmi Angadi [Thu, 23 Feb 2017 17:53:28 +0000 (09:53 -0800)]
add nvme to install.pl

Signed-off-by: Rajalaxmi Angadi <rajalaxmi.angadi@intel.com>
Signed-off-by: Jay Sternberg <jay.e.sternberg@intel.com>
3 years agocorrect install.pl handling of select menu
Jay Sternberg [Fri, 17 Feb 2017 18:00:17 +0000 (10:00 -0800)]
correct install.pl handling of select menu

The select menu removed handling of HPC option but the values
checked to determine what action to take where not updated.
This fixes the issue of not being able to select a custom
configuration.

Signed-off-by: Jay Sternberg <jay.e.sternberg@intel.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Add vmw_pvrdma to list of kernel modules
Adit Ranadive [Mon, 13 Feb 2017 19:08:17 +0000 (11:08 -0800)]
install.pl: Add vmw_pvrdma to list of kernel modules

Hi Vlad,

This is a small patch for the install file to let vmw_pvrdma be
specified in ofed.conf.

Thanks,
Adit

3 years agoinstall.pl: Request ninja on SLES12.x only
Vladimir Sokolovsky [Mon, 30 Jan 2017 12:05:44 +0000 (14:05 +0200)]
install.pl: Request ninja on SLES12.x only

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Require cmake >= 3.5 on SLES12
Vladimir Sokolovsky [Mon, 23 Jan 2017 07:53:18 +0000 (09:53 +0200)]
install.pl: Require cmake >= 3.5 on SLES12

On SLES12 SP0 rdma-core rpmbuild fails due to cmake issues.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Disable nfsrdma
Vladimir Sokolovsky [Mon, 16 Jan 2017 08:26:44 +0000 (10:26 +0200)]
install.pl: Disable nfsrdma

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Force infiniband-diags installation due to conflict with rdma-core
Vladimir Sokolovsky [Sun, 4 Dec 2016 15:54:20 +0000 (17:54 +0200)]
install.pl: Force infiniband-diags installation due to conflict with rdma-core

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Fix dependencies
Vladimir Sokolovsky [Sun, 20 Nov 2016 15:19:14 +0000 (17:19 +0200)]
install.pl: Fix dependencies

Old packages depend on libibverbs/libibumad/...
Add '--nodeps' to rpm build and install command to avoid dependency issues.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Integrate rdma-core package instead of lib*
Vladimir Sokolovsky [Sun, 20 Nov 2016 14:02:40 +0000 (16:02 +0200)]
install.pl: Integrate rdma-core package instead of lib*

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Added RHEL7.3
Vladimir Sokolovsky [Mon, 7 Nov 2016 16:22:36 +0000 (18:22 +0200)]
install.pl: Added RHEL7.3

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Added SLES12 SP2 support
Vladimir Sokolovsky [Mon, 10 Oct 2016 08:23:34 +0000 (11:23 +0300)]
install.pl: Added SLES12 SP2 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoDisable mthca
Vladimir Sokolovsky [Mon, 10 Oct 2016 08:20:19 +0000 (11:20 +0300)]
Disable mthca

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Disable ocrdma and libocrdma packages
Vladimir Sokolovsky [Sun, 9 Oct 2016 12:36:00 +0000 (15:36 +0300)]
install.pl: Disable ocrdma and libocrdma packages

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Add support for kernels up to 4.8
Vladimir Sokolovsky [Sun, 28 Aug 2016 13:50:24 +0000 (16:50 +0300)]
install.pl: Add support for kernels up to 4.8

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoadd dependency check to install.pl
Jay Sternberg [Fri, 20 May 2016 17:54:55 +0000 (10:54 -0700)]
add dependency check to install.pl

add dependency check to kernel modules initially for ibscif's
dependency on scif.symvers

Signed-off-by: Jay Sternberg <jay.e.sternberg@intel.com>
4 years agoAdded SLES12.1 and RHEL7.2 support
Vladimir Sokolovsky [Sun, 3 Jan 2016 16:22:04 +0000 (18:22 +0200)]
Added SLES12.1 and RHEL7.2 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Fixed rpmbuild parameter
Vladimir Sokolovsky [Mon, 19 Oct 2015 15:29:54 +0000 (18:29 +0300)]
install.pl: Fixed rpmbuild parameter

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Fixed infinipath-psm dependencies
Vladimir Sokolovsky [Mon, 19 Oct 2015 15:26:54 +0000 (18:26 +0300)]
install.pl: Fixed infinipath-psm dependencies

issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2578

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinfinipath-psm depends on libibscif when '--with-xeon-phi' used
Vladimir Sokolovsky [Tue, 13 Oct 2015 15:38:57 +0000 (18:38 +0300)]
infinipath-psm depends on libibscif when '--with-xeon-phi' used

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Fixed infinioath-psm installation with libfabric
Vladimir Sokolovsky [Wed, 7 Oct 2015 09:58:17 +0000 (12:58 +0300)]
install.pl: Fixed infinioath-psm installation with libfabric

issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2544

Signed-off-by: Patrick M Mccormick <patrick.m.mccormick@intel.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Disable ib_srp kernel module on PPC64
Vladimir Sokolovsky [Tue, 1 Sep 2015 10:02:34 +0000 (13:02 +0300)]
install.pl: Disable ib_srp kernel module on PPC64

Disable SRP on ppc64 platform to avoid update of scsi_transport_srp kernel module
which will prevent in-box ibmvscsi module load and, as a result, kernel panic upon boot

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Enable libfabric for all platforms
Sean Hefty [Mon, 3 Aug 2015 15:42:46 +0000 (18:42 +0300)]
install.pl: Enable libfabric for all platforms

Signed-off-by: Sean Hefty <sean.hefty@intel.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Restrict fabtest to x86_64 due to dependency issue
Vladimir Sokolovsky [Thu, 11 Jun 2015 13:19:09 +0000 (16:19 +0300)]
install.pl: Restrict fabtest to x86_64 due to dependency issue

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoSet libfabric to be available on x86_64 only
Vladimir Sokolovsky [Wed, 10 Jun 2015 11:42:14 +0000 (14:42 +0300)]
Set libfabric to be available on x86_64 only

This is due to its dependency on infinipath-psm

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall: remove libnl3 requirement and enable libfabrics on all OSes
Vladimir Sokolovsky [Sun, 31 May 2015 06:39:28 +0000 (09:39 +0300)]
install: remove libnl3 requirement and enable libfabrics on all OSes

Also removes unnecessary PSM_HAVE_SCIF during install.
issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2548

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoAdded SLES11.4 and RHEL6.7 support
Vladimir Sokolovsky [Mon, 25 May 2015 13:39:16 +0000 (16:39 +0300)]
Added SLES11.4 and RHEL6.7 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall: Added opensm-libs3 to the list of in-box RPMs for uninstall
Vladimir Sokolovsky [Mon, 11 May 2015 10:38:19 +0000 (13:38 +0300)]
install: Added opensm-libs3 to the list of in-box RPMs for uninstall

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoAdded fabtests support
Vladimir Sokolovsky [Mon, 4 May 2015 06:26:06 +0000 (09:26 +0300)]
Added fabtests support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoRevert "install.pl: Disable nfsrdma on RHEL6 and kernel 3.18"
Vladimir Sokolovsky [Tue, 7 Apr 2015 10:11:05 +0000 (13:11 +0300)]
Revert "install.pl: Disable nfsrdma on RHEL6 and kernel 3.18"

Backports were suppplied

This reverts commit 27043a620ce5a9904b96e277812604f27f2c09f4.

5 years agoinstall.pl: Disable nfsrdma on RHEL6 and kernel 3.18
Vladimir Sokolovsky [Mon, 30 Mar 2015 16:22:36 +0000 (19:22 +0300)]
install.pl: Disable nfsrdma on RHEL6 and kernel 3.18

NFSRDMA is temporary disabled due to compilation issues:
2523, 2524, 2525

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoRevert: "install.pl: Disable nfsrdma on SLES11 SP3"
Vladimir Sokolovsky [Mon, 16 Mar 2015 14:08:57 +0000 (16:08 +0200)]
Revert: "install.pl: Disable nfsrdma on SLES11 SP3"

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Disable cxgbi drivers as not supported by Chelsio
Vladimir Sokolovsky [Wed, 11 Mar 2015 17:16:00 +0000 (19:16 +0200)]
install.pl: Disable cxgbi drivers as not supported by Chelsio

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Fix typo
Vladimir Sokolovsky [Wed, 11 Mar 2015 17:01:43 +0000 (19:01 +0200)]
install.pl: Fix typo

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Disable nfsrdma on SLES11 SP3
Vladimir Sokolovsky [Wed, 11 Mar 2015 16:47:16 +0000 (18:47 +0200)]
install.pl: Disable nfsrdma on SLES11 SP3

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Fix libfabric availability
Vladimir Sokolovsky [Wed, 11 Mar 2015 16:38:05 +0000 (18:38 +0200)]
install.pl: Fix libfabric availability

libfabric depends on libnl3 which is not available on all supported OSes

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: infiniband-diags is now dependent on libudev-devel
Vladimir Sokolovsky [Wed, 11 Mar 2015 15:47:24 +0000 (17:47 +0200)]
install.pl: infiniband-diags is now dependent on libudev-devel

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Fixed dependency on libnl
Vladimir Sokolovsky [Wed, 4 Mar 2015 12:11:26 +0000 (14:11 +0200)]
install.pl: Fixed dependency on libnl

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoadd libfabric
pmmccorm [Fri, 6 Feb 2015 19:29:29 +0000 (11:29 -0800)]
add libfabric

5 years agoinstall.pl: Added RHEL7.1
Vladimir Sokolovsky [Sun, 11 Jan 2015 16:20:37 +0000 (18:20 +0200)]
install.pl: Added RHEL7.1

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Remove unused code
Vladimir Sokolovsky [Thu, 8 Jan 2015 14:41:32 +0000 (16:41 +0200)]
install.pl: Remove unused code

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Updated list of RPMs coming with Distros
Vladimir Sokolovsky [Mon, 5 Jan 2015 18:10:55 +0000 (20:10 +0200)]
install.pl: Updated list of RPMs coming with Distros

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoMerge branch 'ofed_3_12' into ofed_3_18
Vladimir Sokolovsky [Sun, 14 Dec 2014 13:47:55 +0000 (15:47 +0200)]
Merge branch 'ofed_3_12' into ofed_3_18

5 years agoinstall.pl: Added cxgb3/4i to the list of ulp modules
Vladimir Sokolovsky [Wed, 19 Nov 2014 12:47:43 +0000 (14:47 +0200)]
install.pl: Added cxgb3/4i to the list of ulp modules

Signed-off-by: Steve Wise <swise@opengridcomputing.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Build intel-mic-psm as needed
Kyle Liddell [Thu, 6 Nov 2014 22:48:12 +0000 (14:48 -0800)]
install.pl: Build intel-mic-psm as needed

When xeon-phi support is enabled, the install script passes extra build
arguments for infinipath-psm, producing a new package intel-mic-psm that
should be installed in place of infinipath-psm.

Signed-off-by: Kyle Liddell <kyle.liddell@intel.com>
Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
5 years agoAdding libiwpm to the OFED-3.18 install script
Tatyana E. Nikolova [Mon, 3 Nov 2014 22:54:22 +0000 (14:54 -0800)]
Adding libiwpm to the OFED-3.18 install script

5 years agoinstall.pl: Added new parameters for kernel source/obj definition
Vladimir Sokolovsky [Sun, 2 Nov 2014 19:42:04 +0000 (21:42 +0200)]
install.pl: Added new parameters for kernel source/obj definition

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoMerge branch 'ofed_3_12' into ofed_3_18
Vladimir Sokolovsky [Sun, 2 Nov 2014 19:12:40 +0000 (21:12 +0200)]
Merge branch 'ofed_3_12' into ofed_3_18

5 years agouninstall.sh: Replaced by perl script
Vladimir Sokolovsky [Sun, 2 Nov 2014 19:08:47 +0000 (21:08 +0200)]
uninstall.sh: Replaced by perl script

The new script use ofed_info to get the list of installed OFED RPMs.
Then, it builds a list of dependent RPMs for uninstall.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Remove kernel version check for qib/ipathverbs
Jubin John [Tue, 28 Oct 2014 00:29:39 +0000 (17:29 -0700)]
install.pl: Remove kernel version check for qib/ipathverbs

The new compat/compat-rdma scheme allows for all
x86_64 kernels <= 3.12 to compile qib.  This testing is a
vestige of the OFED 1.5.x and a lingering maintenance
issue.

This patch deletes the test.

Signed-off-by: Jubin John <jubin.john@intel.com>
Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
5 years agoinstall.pl: Added support for kernels up to 3.18
Vladimir Sokolovsky [Mon, 27 Oct 2014 14:22:05 +0000 (16:22 +0200)]
install.pl: Added support for kernels up to 3.18

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoRevert "install.pl: Disable infinipath-psm on RHEL7 and SLES12"
Vladimir Sokolovsky [Mon, 20 Oct 2014 14:46:12 +0000 (17:46 +0300)]
Revert "install.pl: Disable infinipath-psm on RHEL7 and SLES12"

This reverts commit 5895319abe5a1cfd31836f7815231b535ffa3422.

5 years agoinstall.pl: Disable infinipath-psm on RHEL7 and SLES12
Vladimir Sokolovsky [Mon, 29 Sep 2014 12:18:07 +0000 (15:18 +0300)]
install.pl: Disable infinipath-psm on RHEL7 and SLES12

issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2475

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>