Add initial 2.6.22 support
[~emulex/for-vlad/old/compat.git] / include / linux / compat-2.6.18.h
1 #ifndef LINUX_26_18_COMPAT_H
2 #define LINUX_26_18_COMPAT_H
3
4 #include <linux/autoconf.h>
5 #include <linux/version.h>
6
7 /* Compat work for 2.6.18 */
8 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18))
9
10 #define roundup(x, y)   ((((x) + ((y) - 1)) / (y)) * (y))
11
12 #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)) */
13
14 #endif /* LINUX_26_18_COMPAT_H */