Add initial 2.6.22 support
[~emulex/for-vlad/old/compat.git] / include / linux / compat-2.6.21.h
1 #ifndef LINUX_26_21_COMPAT_H
2 #define LINUX_26_21_COMPAT_H
3
4 #include <linux/autoconf.h>
5 #include <linux/version.h>
6
7 /* Compat work for 2.6.21 */
8 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,21))
9
10 #include <linux/sysctl.h>
11
12 #define register_sysctl_table(table)                            \
13         ({                                                      \
14                 register_sysctl_table((table), 0);              \
15         })
16
17 #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,21)) */
18
19 #endif /* LINUX_26_21_COMPAT_H */