Enable 2.6.33 compatibility
[~emulex/for-vlad/old/compat.git] / include / linux / compat-2.6.21.h
1 #ifndef LINUX_26_21_COMPAT_H
2 #define LINUX_26_21_COMPAT_H
3
4 #include <linux/version.h>
5
6 /* Compat work for 2.6.21 */
7 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,21))
8
9 #include <linux/sysctl.h>
10
11 #define register_sysctl_table(table)                            \
12         ({                                                      \
13                 register_sysctl_table((table), 0);              \
14         })
15
16 #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,21)) */
17
18 #endif /* LINUX_26_21_COMPAT_H */