compat: Add support for 3.12
[~emulex/for-vlad/old/compat.git] / include / linux / compat-3.10.h
1 #ifndef LINUX_3_10_COMPAT_H
2 #define LINUX_3_10_COMPAT_H
3
4 #include <linux/version.h>
5
6 #if (LINUX_VERSION_CODE < KERNEL_VERSION(3,10,0))
7
8 #include <linux/if_vlan.h>
9 #define __vlan_hwaccel_put_tag(a, b, c) __vlan_hwaccel_put_tag(a, c)
10
11 #include <linux/netdev_features.h>
12 #define NETIF_F_HW_VLAN_CTAG_RX NETIF_F_HW_VLAN_RX
13
14 #endif /* LINUX_VERSION_CODE < KERNEL_VERSION(3,10,0) */
15
16 #endif /* LINUX_3_10_COMPAT_H */