compat: Add support for 3.12
[~emulex/for-vlad/old/compat.git] / include / linux / compat-3.12.h
1 #ifndef LINUX_3_12_COMPAT_H
2 #define LINUX_3_12_COMPAT_H
3
4 #include <linux/version.h>
5
6 #if (LINUX_VERSION_CODE < KERNEL_VERSION(3,12,0))
7
8 #define PTR_ERR_OR_ZERO LINUX_BACKPORT(PTR_ERR_OR_ZERO)
9 static inline int __must_check PTR_ERR_OR_ZERO(__force const void *ptr)
10 {
11         if (IS_ERR(ptr))
12                 return PTR_ERR(ptr);
13         else
14                 return 0;
15 }
16 #endif /* LINUX_VERSION_CODE < KERNEL_VERSION(3,12,0) */
17
18 #endif /* LINUX_3_12_COMPAT_H */