Fix build with CONFIG_PCMCIA disabled
[~emulex/for-vlad/old/compat.git] / include / linux / compat-2.6.33.h
index 73fc91c..9559f21 100644 (file)
@@ -6,9 +6,13 @@
 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
 
 #include <linux/skbuff.h>
+#if defined(CONFIG_PCCARD) || defined(CONFIG_PCCARD_MODULE)
+#if defined(CONFIG_PCMCIA) || defined(CONFIG_PCMCIA_MODULE)
 #include <pcmcia/cs_types.h>
 #include <pcmcia/cistpl.h>
 #include <pcmcia/ds.h>
+#endif
+#endif
 #include <linux/kfifo.h>
 #include <linux/firmware.h>