compat: kernels <= 3.0 handle netlink_dump_start API change
authorMike Marciniszyn <mike.marciniszyn@intel.com>
Mon, 21 May 2012 12:58:32 +0000 (08:58 -0400)
committerMike Marciniszyn <mike.marciniszyn@intel.com>
Mon, 21 May 2012 12:58:32 +0000 (08:58 -0400)
commit12656343a90b0a5a216dfed5d31c42a2268fe13d
tree8ec2302f19f12cf91bb2b8aa85b3aca492e9b03d
parent7823ad8b99ba77e92439419e78d1de7c305cb6c8
compat: kernels <= 3.0 handle netlink_dump_start API change

Older kernels don't have the last min_dump_alloc_arg to
netlink_dump_start().

The arg removal can be disarmed with the
NEED_MIN_DUMP_ALLOC_ARG to support compilation on
SLES11SP2, which has the arg.

Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
include/linux/compat-3.1.h