compat: fix build for kernel < 2.6.29
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 31 Mar 2011 16:21:34 +0000 (09:21 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Thu, 31 Mar 2011 19:15:41 +0000 (12:15 -0700)
get_irq_desc_chip(), get_irq_desc_data(), get_irq_desc_chip_data() and
get_irq_desc_msi() are not available in kernel < 2.6.29.

Luis please add this into the linux-2.6.39.y branch.

Cc: Thomas Gleixner <tglx@linutronix.de>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/linux/compat-2.6.39.h

index 2c62d90..104fce0 100644 (file)
@@ -71,6 +71,8 @@ static inline void irq_set_probe(unsigned int irq)
 {
        set_irq_probe(irq);
 }
+
+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29))
 static inline struct irq_chip *irq_desc_get_chip(struct irq_desc *desc)
 {
        return get_irq_desc_chip(desc);
@@ -89,6 +91,7 @@ static inline struct msi_desc *irq_desc_get_msi_desc(struct irq_desc *desc)
 {
        return get_irq_desc_msi(desc);
 }
+#endif /* (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29)) */
 
 #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,39)) */