compat: fix pm_qos_params compile error on 2.6.35
authorFelix Fietkau <nbd@openwrt.org>
Fri, 12 Nov 2010 19:14:44 +0000 (11:14 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Fri, 12 Nov 2010 19:14:44 +0000 (11:14 -0800)
Linux 2.6.35 pm_qos_params.h is missing a #ifndef/define/endif around
its header file contents, causing a compile error when its functions
are overwritten by macros in the compat header files.
Fix this by adding these to the compat version of this header file.

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
include/linux/pm_qos_params.h

index e1f083c..d0e3ad8 100644 (file)
@@ -1,5 +1,8 @@
 #include <linux/version.h>
 
+#ifndef __COMPAT_LINUX_PM_QOS_PARAMS_H
+#define __COMPAT_LINUX_PM_QOS_PARAMS_H
+
 #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,25))
 #include_next <linux/pm_qos_params.h>
 #else
@@ -30,3 +33,4 @@ int pm_qos_add_notifier(int qos, struct notifier_block *notifier);
 int pm_qos_remove_notifier(int qos, struct notifier_block *notifier);
 #endif /* (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,25)) */
 
+#endif