compat: include compat-3.5