compat: fix compilation warning on compat-3.5.c