x86, hyperv: HYPERV depends on X86_LOCAL_APIC
[~shefty/rdma-dev.git] / drivers / hv / Kconfig
1 menu "Microsoft Hyper-V guest support"
2
3 config HYPERV
4         tristate "Microsoft Hyper-V client drivers"
5         depends on X86 && ACPI && PCI && X86_LOCAL_APIC
6         help
7           Select this option to run Linux as a Hyper-V client operating
8           system.
9
10 config HYPERV_UTILS
11         tristate "Microsoft Hyper-V Utilities driver"
12         depends on HYPERV && CONNECTOR && NLS
13         help
14           Select this option to enable the Hyper-V Utilities.
15
16 config HYPERV_BALLOON
17         tristate "Microsoft Hyper-V Balloon driver"
18         depends on HYPERV
19         help
20           Select this option to enable Hyper-V Balloon driver.
21
22 endmenu