x86, hyperv: HYPERV depends on X86_LOCAL_APIC
[~shefty/rdma-dev.git] / drivers / hv / Kconfig
index b38ef6d8d0492d7392814021f7ac30c7813ab361..64630f15f1816231ddc83feb88eab58e872cca3d 100644 (file)
@@ -2,7 +2,7 @@ menu "Microsoft Hyper-V guest support"
 
 config HYPERV
        tristate "Microsoft Hyper-V client drivers"
-       depends on X86 && ACPI && PCI
+       depends on X86 && ACPI && PCI && X86_LOCAL_APIC
        help
          Select this option to run Linux as a Hyper-V client operating
          system.