compat: add tty_set_termios only for kernel >= 2.6.27
[~tnikolova/compat/.git] / include / linux / compat-2.6.39.h
index 1c7b322..0c4f030 100644 (file)
@@ -27,7 +27,9 @@
 #define tiocmget(tty) tiocmget(tty, NULL)
 #define tiocmset(tty, set, clear) tiocmset(tty, NULL, set, clear)
 
+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,27))
 extern int tty_set_termios(struct tty_struct *tty, struct ktermios *kt);
+#endif /* (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,27)) */
 
 #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,39)) */