Added checks required to support RHEL7.1