compat-2.6.29.h: Avoid include on kernels > 2.6.29