compat: add some workarounds for Debian squeeze