~tnikolova/ofed_scripts/.git
3 years agoinstall.pl: Set __arch_install_post to nil ofed_3_18 origin/ofed_3_18
Vladimir Sokolovsky [Thu, 16 Feb 2017 09:32:29 +0000 (11:32 +0200)]
install.pl: Set __arch_install_post to nil

This is to avoid rpmbuild failure in case of redefinition of this macro by user.
issue: http://bugs.openfabrics.org/show_bug.cgi?id=2598

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
3 years agoinstall.pl: Added RHEL6.8 support
Vladimir Sokolovsky [Wed, 4 Jan 2017 15:28:32 +0000 (17:28 +0200)]
install.pl: Added RHEL6.8 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoadd dependency check to install.pl
Jay Sternberg [Fri, 20 May 2016 17:54:55 +0000 (10:54 -0700)]
add dependency check to install.pl

add dependency check to kernel modules initially for ibscif's
dependency on scif.symvers

Signed-off-by: Jay Sternberg <jay.e.sternberg@intel.com>
4 years agoAdded SLES12.1 and RHEL7.2 support
Vladimir Sokolovsky [Sun, 3 Jan 2016 16:22:04 +0000 (18:22 +0200)]
Added SLES12.1 and RHEL7.2 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Fixed rpmbuild parameter vofed-3.18-1
Vladimir Sokolovsky [Mon, 19 Oct 2015 15:29:54 +0000 (18:29 +0300)]
install.pl: Fixed rpmbuild parameter

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Fixed infinipath-psm dependencies
Vladimir Sokolovsky [Mon, 19 Oct 2015 15:26:54 +0000 (18:26 +0300)]
install.pl: Fixed infinipath-psm dependencies

issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2578

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinfinipath-psm depends on libibscif when '--with-xeon-phi' used
Vladimir Sokolovsky [Tue, 13 Oct 2015 15:38:57 +0000 (18:38 +0300)]
infinipath-psm depends on libibscif when '--with-xeon-phi' used

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Fixed infinioath-psm installation with libfabric
Vladimir Sokolovsky [Wed, 7 Oct 2015 09:58:17 +0000 (12:58 +0300)]
install.pl: Fixed infinioath-psm installation with libfabric

issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2544

Signed-off-by: Patrick M Mccormick <patrick.m.mccormick@intel.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Disable ib_srp kernel module on PPC64
Vladimir Sokolovsky [Tue, 1 Sep 2015 10:02:34 +0000 (13:02 +0300)]
install.pl: Disable ib_srp kernel module on PPC64

Disable SRP on ppc64 platform to avoid update of scsi_transport_srp kernel module
which will prevent in-box ibmvscsi module load and, as a result, kernel panic upon boot

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
4 years agoinstall.pl: Enable libfabric for all platforms
Sean Hefty [Mon, 3 Aug 2015 15:42:46 +0000 (18:42 +0300)]
install.pl: Enable libfabric for all platforms

Signed-off-by: Sean Hefty <sean.hefty@intel.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Restrict fabtest to x86_64 due to dependency issue
Vladimir Sokolovsky [Thu, 11 Jun 2015 13:19:09 +0000 (16:19 +0300)]
install.pl: Restrict fabtest to x86_64 due to dependency issue

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoSet libfabric to be available on x86_64 only
Vladimir Sokolovsky [Wed, 10 Jun 2015 11:42:14 +0000 (14:42 +0300)]
Set libfabric to be available on x86_64 only

This is due to its dependency on infinipath-psm

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall: remove libnl3 requirement and enable libfabrics on all OSes
Vladimir Sokolovsky [Sun, 31 May 2015 06:39:28 +0000 (09:39 +0300)]
install: remove libnl3 requirement and enable libfabrics on all OSes

Also removes unnecessary PSM_HAVE_SCIF during install.
issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2548

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoAdded SLES11.4 and RHEL6.7 support
Vladimir Sokolovsky [Mon, 25 May 2015 13:39:16 +0000 (16:39 +0300)]
Added SLES11.4 and RHEL6.7 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall: Added opensm-libs3 to the list of in-box RPMs for uninstall
Vladimir Sokolovsky [Mon, 11 May 2015 10:38:19 +0000 (13:38 +0300)]
install: Added opensm-libs3 to the list of in-box RPMs for uninstall

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoAdded fabtests support
Vladimir Sokolovsky [Mon, 4 May 2015 06:26:06 +0000 (09:26 +0300)]
Added fabtests support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoRevert "install.pl: Disable nfsrdma on RHEL6 and kernel 3.18"
Vladimir Sokolovsky [Tue, 7 Apr 2015 10:11:05 +0000 (13:11 +0300)]
Revert "install.pl: Disable nfsrdma on RHEL6 and kernel 3.18"

Backports were suppplied

This reverts commit 27043a620ce5a9904b96e277812604f27f2c09f4.

5 years agoinstall.pl: Disable nfsrdma on RHEL6 and kernel 3.18
Vladimir Sokolovsky [Mon, 30 Mar 2015 16:22:36 +0000 (19:22 +0300)]
install.pl: Disable nfsrdma on RHEL6 and kernel 3.18

NFSRDMA is temporary disabled due to compilation issues:
2523, 2524, 2525

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoRevert: "install.pl: Disable nfsrdma on SLES11 SP3"
Vladimir Sokolovsky [Mon, 16 Mar 2015 14:08:57 +0000 (16:08 +0200)]
Revert: "install.pl: Disable nfsrdma on SLES11 SP3"

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Disable cxgbi drivers as not supported by Chelsio
Vladimir Sokolovsky [Wed, 11 Mar 2015 17:16:00 +0000 (19:16 +0200)]
install.pl: Disable cxgbi drivers as not supported by Chelsio

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Fix typo
Vladimir Sokolovsky [Wed, 11 Mar 2015 17:01:43 +0000 (19:01 +0200)]
install.pl: Fix typo

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Disable nfsrdma on SLES11 SP3
Vladimir Sokolovsky [Wed, 11 Mar 2015 16:47:16 +0000 (18:47 +0200)]
install.pl: Disable nfsrdma on SLES11 SP3

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Fix libfabric availability
Vladimir Sokolovsky [Wed, 11 Mar 2015 16:38:05 +0000 (18:38 +0200)]
install.pl: Fix libfabric availability

libfabric depends on libnl3 which is not available on all supported OSes

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: infiniband-diags is now dependent on libudev-devel
Vladimir Sokolovsky [Wed, 11 Mar 2015 15:47:24 +0000 (17:47 +0200)]
install.pl: infiniband-diags is now dependent on libudev-devel

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Fixed dependency on libnl
Vladimir Sokolovsky [Wed, 4 Mar 2015 12:11:26 +0000 (14:11 +0200)]
install.pl: Fixed dependency on libnl

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoadd libfabric
pmmccorm [Fri, 6 Feb 2015 19:29:29 +0000 (11:29 -0800)]
add libfabric

5 years agoinstall.pl: Added RHEL7.1
Vladimir Sokolovsky [Sun, 11 Jan 2015 16:20:37 +0000 (18:20 +0200)]
install.pl: Added RHEL7.1

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Remove unused code
Vladimir Sokolovsky [Thu, 8 Jan 2015 14:41:32 +0000 (16:41 +0200)]
install.pl: Remove unused code

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Updated list of RPMs coming with Distros
Vladimir Sokolovsky [Mon, 5 Jan 2015 18:10:55 +0000 (20:10 +0200)]
install.pl: Updated list of RPMs coming with Distros

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoMerge branch 'ofed_3_12' into ofed_3_18
Vladimir Sokolovsky [Sun, 14 Dec 2014 13:47:55 +0000 (15:47 +0200)]
Merge branch 'ofed_3_12' into ofed_3_18

5 years agoinstall.pl: Added cxgb3/4i to the list of ulp modules
Vladimir Sokolovsky [Wed, 19 Nov 2014 12:47:43 +0000 (14:47 +0200)]
install.pl: Added cxgb3/4i to the list of ulp modules

Signed-off-by: Steve Wise <swise@opengridcomputing.com>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Build intel-mic-psm as needed origin/ofed_3_12
Kyle Liddell [Thu, 6 Nov 2014 22:48:12 +0000 (14:48 -0800)]
install.pl: Build intel-mic-psm as needed

When xeon-phi support is enabled, the install script passes extra build
arguments for infinipath-psm, producing a new package intel-mic-psm that
should be installed in place of infinipath-psm.

Signed-off-by: Kyle Liddell <kyle.liddell@intel.com>
Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
5 years agoAdding libiwpm to the OFED-3.18 install script
Tatyana E. Nikolova [Mon, 3 Nov 2014 22:54:22 +0000 (14:54 -0800)]
Adding libiwpm to the OFED-3.18 install script

5 years agoinstall.pl: Added new parameters for kernel source/obj definition
Vladimir Sokolovsky [Sun, 2 Nov 2014 19:42:04 +0000 (21:42 +0200)]
install.pl: Added new parameters for kernel source/obj definition

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoMerge branch 'ofed_3_12' into ofed_3_18
Vladimir Sokolovsky [Sun, 2 Nov 2014 19:12:40 +0000 (21:12 +0200)]
Merge branch 'ofed_3_12' into ofed_3_18

5 years agouninstall.sh: Replaced by perl script
Vladimir Sokolovsky [Sun, 2 Nov 2014 19:08:47 +0000 (21:08 +0200)]
uninstall.sh: Replaced by perl script

The new script use ofed_info to get the list of installed OFED RPMs.
Then, it builds a list of dependent RPMs for uninstall.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Remove kernel version check for qib/ipathverbs
Jubin John [Tue, 28 Oct 2014 00:29:39 +0000 (17:29 -0700)]
install.pl: Remove kernel version check for qib/ipathverbs

The new compat/compat-rdma scheme allows for all
x86_64 kernels <= 3.12 to compile qib.  This testing is a
vestige of the OFED 1.5.x and a lingering maintenance
issue.

This patch deletes the test.

Signed-off-by: Jubin John <jubin.john@intel.com>
Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
5 years agoinstall.pl: Added support for kernels up to 3.18
Vladimir Sokolovsky [Mon, 27 Oct 2014 14:22:05 +0000 (16:22 +0200)]
install.pl: Added support for kernels up to 3.18

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoRevert "install.pl: Disable infinipath-psm on RHEL7 and SLES12"
Vladimir Sokolovsky [Mon, 20 Oct 2014 14:46:12 +0000 (17:46 +0300)]
Revert "install.pl: Disable infinipath-psm on RHEL7 and SLES12"

This reverts commit 5895319abe5a1cfd31836f7815231b535ffa3422.

5 years agoinstall.pl: Disable infinipath-psm on RHEL7 and SLES12
Vladimir Sokolovsky [Mon, 29 Sep 2014 12:18:07 +0000 (15:18 +0300)]
install.pl: Disable infinipath-psm on RHEL7 and SLES12

issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2475

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Added RHEL6.6 support
Vladimir Sokolovsky [Mon, 29 Sep 2014 12:17:09 +0000 (15:17 +0300)]
install.pl: Added RHEL6.6 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Removed trailing whitespaces
Vladimir Sokolovsky [Mon, 18 Aug 2014 10:28:49 +0000 (13:28 +0300)]
install.pl: Removed trailing whitespaces

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoinstall.pl: Fix ibutils configuration parameters on SLES12
Vladimir Sokolovsky [Mon, 18 Aug 2014 10:23:30 +0000 (13:23 +0300)]
install.pl: Fix ibutils configuration parameters on SLES12

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
5 years agoRevert "install.pl: Disable dapl-debuginfo"
Vladimir Sokolovsky [Thu, 14 Aug 2014 08:52:09 +0000 (11:52 +0300)]
Revert "install.pl: Disable dapl-debuginfo"

This reverts commit 4ded3cdd2251bfcce78aec037d55a3909873fb6e.

5 years agoadd xeon-phi as tech preview
Phil Cayton [Wed, 6 Aug 2014 20:29:49 +0000 (13:29 -0700)]
add xeon-phi as tech preview

5 years agoinstall.pl: Disable dapl-debuginfo
Vladimir Sokolovsky [Wed, 6 Aug 2014 12:38:51 +0000 (15:38 +0300)]
install.pl: Disable dapl-debuginfo

dapl-debuginfo is not created after updating dapl version.

issue: http://bugs.openfabrics.org/bugzilla/show_bug.cgi?id=2497

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Added SLES12 support
Vladimir Sokolovsky [Tue, 17 Jun 2014 08:23:25 +0000 (11:23 +0300)]
install.pl: Added SLES12 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoSet local language to en_US.UTF-8
Vladimir Sokolovsky [Tue, 17 Jun 2014 07:05:23 +0000 (10:05 +0300)]
Set local language to en_US.UTF-8

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Enable iser
Vladimir Sokolovsky [Mon, 16 Jun 2014 15:18:08 +0000 (18:18 +0300)]
install.pl: Enable iser

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Added RHEL7 support vofed-3.12
Vladimir Sokolovsky [Wed, 19 Mar 2014 11:38:45 +0000 (13:38 +0200)]
install.pl: Added RHEL7 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: mstflint depends on libibmad
Vladimir Sokolovsky [Mon, 17 Mar 2014 14:52:33 +0000 (16:52 +0200)]
install.pl: mstflint depends on libibmad

issue: http://bugs.openfabrics.org/show_bug.cgi?id=2472

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Temporary skip dependency check for libmlx4
Vladimir Sokolovsky [Mon, 17 Feb 2014 13:54:16 +0000 (15:54 +0200)]
install.pl: Temporary skip dependency check for libmlx4

The code can be compiled over libibverbs but the dependency check requires
specific release number.  Waiting for libibverbs-1.1.8 release.
This commit should be reverted afterwards.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Added RHEL6.5 support
Vladimir Sokolovsky [Thu, 23 Jan 2014 16:54:48 +0000 (18:54 +0200)]
install.pl: Added RHEL6.5 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Added '--without-<package>' parameter support
Vladimir Sokolovsky [Thu, 23 Jan 2014 11:16:53 +0000 (13:16 +0200)]
install.pl: Added '--without-<package>' parameter support

This is to provide an easy way to avoid package installation.
Number of such parameters can be provided to the install.pl script:
E.g.: ./install.pl --all --without-rds-tools --without-ibacm --without-mthca

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoAdded ocrdma kernel module support
Vladimir Sokolovsky [Mon, 11 Nov 2013 16:12:23 +0000 (18:12 +0200)]
Added ocrdma kernel module support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoAdded libocrdma support
Vladimir Sokolovsky [Mon, 11 Nov 2013 15:48:09 +0000 (17:48 +0200)]
Added libocrdma support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agouninstall.sh: Remove libmlx5 origin/compat-rdma
Vladimir Sokolovsky [Thu, 7 Nov 2013 12:21:36 +0000 (14:21 +0200)]
uninstall.sh: Remove libmlx5

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Added mlx5 support
Vladimir Sokolovsky [Thu, 7 Nov 2013 12:20:49 +0000 (14:20 +0200)]
install.pl: Added mlx5 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Updated for OFED-3.12
Vladimir Sokolovsky [Thu, 7 Nov 2013 12:17:05 +0000 (14:17 +0200)]
install.pl: Updated for OFED-3.12

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Extend support up to kernel 3.12
Vladimir Sokolovsky [Mon, 30 Sep 2013 15:56:43 +0000 (18:56 +0300)]
install.pl: Extend support up to kernel 3.12

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Fix release number for compat-rdma RPM vofed-3.5
Vladimir Sokolovsky [Tue, 27 Aug 2013 12:55:31 +0000 (15:55 +0300)]
install.pl: Fix release number for compat-rdma RPM

Include source RPM release number along with kernel version

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Fix '-p' option
Vladimir Sokolovsky [Mon, 19 Aug 2013 12:57:07 +0000 (15:57 +0300)]
install.pl: Fix '-p' option

Unsupported packages will not be added to ofed.conf file
bug: 2373

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: glib2-devel is required by infiniband diags
Vladimir Sokolovsky [Mon, 19 Aug 2013 12:08:47 +0000 (15:08 +0300)]
install.pl: glib2-devel is required by infiniband diags

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
6 years agoinstall.pl: Added SLES11SP3 support
Vladimir Sokolovsky [Thu, 25 Jul 2013 15:13:17 +0000 (18:13 +0300)]
install.pl: Added SLES11SP3 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
7 years agoinstall.pl: Added RHEL6.4 support
Vladimir Sokolovsky [Wed, 22 May 2013 16:50:37 +0000 (19:50 +0300)]
install.pl: Added RHEL6.4 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
7 years agoinstall.pl: Enable NFSRDMA on RHEL6.2/3
Vladimir Sokolovsky [Mon, 3 Sep 2012 08:12:23 +0000 (11:12 +0300)]
install.pl: Enable NFSRDMA on RHEL6.2/3

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
7 years agoinstall.pl: enable qib/ipathverbs for SLES11SP2
Mike Marciniszyn [Tue, 28 Aug 2012 19:19:40 +0000 (15:19 -0400)]
install.pl: enable qib/ipathverbs for SLES11SP2

Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
7 years agoinstall.pl: Enable nfsrdma on SLES11SP2
Vladimir Sokolovsky [Tue, 21 Aug 2012 15:45:33 +0000 (18:45 +0300)]
install.pl: Enable nfsrdma on SLES11SP2

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
7 years agoinstall.pl: restore qperf default install option
Mike Marciniszyn [Wed, 15 Aug 2012 17:09:08 +0000 (13:09 -0400)]
install.pl: restore qperf default install option

unwind 47f257 ("install.pl: Disable qperf").  The 0.4.7 version
corrects the issue.

Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
7 years agoinstall.pl: Add new OSes support and update uninstall
Vladimir Sokolovsky [Sun, 5 Aug 2012 21:12:01 +0000 (00:12 +0300)]
install.pl: Add new OSes support and update uninstall

Add RHEL6.3 and other RedHat like OSes support.
uninstall will remove automatically RPMs dependent on OFED RPMs.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
7 years agoinstall.pl: Disable RDS and SRPT
Vladimir Sokolovsky [Sun, 5 Aug 2012 19:57:50 +0000 (22:57 +0300)]
install.pl: Disable RDS and SRPT

There are no backports for RDS and SRPT yet.

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Extend the range of supported kernels up to 3.5
Vladimir Sokolovsky [Mon, 2 Jul 2012 08:17:53 +0000 (11:17 +0300)]
install.pl: Extend the range of supported kernels up to 3.5

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Disable qperf origin/compat-rdma-3.2
Vladimir Sokolovsky [Thu, 23 Feb 2012 11:01:28 +0000 (13:01 +0200)]
install.pl: Disable qperf

qperf rpmbuild fails over upstream libibverbs due to XRC dependency

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Remove SDP support
Vladimir Sokolovsky [Wed, 22 Feb 2012 17:18:49 +0000 (19:18 +0200)]
install.pl: Remove SDP support

SDP is not available upstream

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: define release field for compat-rdma
Vladimir Sokolovsky [Tue, 21 Feb 2012 17:38:19 +0000 (19:38 +0200)]
install.pl: define release field for compat-rdma

Set release field to include kernel version

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoUpdate for compat-rdma support
Vladimir Sokolovsky [Sun, 19 Feb 2012 14:29:24 +0000 (16:29 +0200)]
Update for compat-rdma support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Disable NES and RDS on 3.1 kernel origin/ofed_1_5
Vladimir Sokolovsky [Mon, 30 Jan 2012 10:51:30 +0000 (12:51 +0200)]
install.pl: Disable NES and RDS on 3.1 kernel

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: remove open-iscsi and tgt RPMs vofed-1.5.4.1
Vladimir Sokolovsky [Mon, 23 Jan 2012 10:13:37 +0000 (12:13 +0200)]
install.pl: remove open-iscsi and tgt RPMs

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Remove rnfs-utils
Vladimir Sokolovsky [Mon, 23 Jan 2012 07:41:33 +0000 (09:41 +0200)]
install.pl: Remove rnfs-utils

This package is not required on the new OSes where nfsrdma is supported:
SLES11SP1 and RHEL6.1

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: pciutils is required by kernel-ib RPM
Vladimir Sokolovsky [Sun, 22 Jan 2012 16:34:41 +0000 (18:34 +0200)]
install.pl: pciutils is required by kernel-ib RPM

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Fix blkid_pkg RPM name
Vladimir Sokolovsky [Sun, 22 Jan 2012 16:29:33 +0000 (18:29 +0200)]
install.pl: Fix blkid_pkg RPM name

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Change libstdc RPM name for SLES11SP2
Vladimir Sokolovsky [Sun, 22 Jan 2012 16:05:38 +0000 (18:05 +0200)]
install.pl: Change libstdc RPM name for SLES11SP2

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Add new Distros support
Vladimir Sokolovsky [Sun, 22 Jan 2012 15:53:28 +0000 (17:53 +0200)]
install.pl: Add new Distros support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoAdd kernel 3.1 support
Vladimir Sokolovsky [Thu, 8 Dec 2011 13:07:21 +0000 (15:07 +0200)]
Add kernel 3.1 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoAdd sparc support
Vladimir Sokolovsky [Thu, 24 Nov 2011 15:21:48 +0000 (17:21 +0200)]
Add sparc support

Signed-off-by: Lukas Razik <linux@razik.name>
Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoAdd nfsrdma and rnfs-utils to the list of packages to be installed with '--all'
Vladimir Sokolovsky [Thu, 10 Nov 2011 10:31:03 +0000 (12:31 +0200)]
Add nfsrdma and rnfs-utils to the list of packages to be installed with '--all'

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoinstall.pl: Update the list of OSes supported by NFSRDMA
Vladimir Sokolovsky [Thu, 10 Nov 2011 09:54:29 +0000 (11:54 +0200)]
install.pl: Update the list of OSes supported by NFSRDMA

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.com>
8 years agoDisable f77 and fc bindings if no fortran compiler
Jonathan Perkins [Wed, 9 Nov 2011 17:29:35 +0000 (12:29 -0500)]
Disable f77 and fc bindings if no fortran compiler

8 years agoinstall.pl: Add support for the new kernels and OSes
Vladimir Sokolovsky [Tue, 18 Oct 2011 18:52:03 +0000 (20:52 +0200)]
install.pl: Add support for the new kernels and OSes

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
8 years agoinstall.pl: Fix mvapich2-1.7.rc1 build failure
Jonathan Perkins [Tue, 20 Sep 2011 20:43:34 +0000 (23:43 +0300)]
install.pl: Fix mvapich2-1.7.rc1 build failure

Signed-off-by: Jonathan Perkins <perkinjo@cse.ohio-state.edu>
8 years agoofed_scripts/install.pl: Enhance install.pl qib kernels
Mike Marciniszyn [Thu, 1 Sep 2011 15:52:08 +0000 (11:52 -0400)]
ofed_scripts/install.pl: Enhance install.pl qib kernels

This patch modifies the install.pl script so that the
ib_qib driver will be installed on newer SLES kernels.

Signed-off-by: Mike Marciniszyn <mike.marciniszyn@qlogic.com>
8 years agoAdd cxgb4
Vladimir Sokolovsky [Thu, 28 Jul 2011 15:40:07 +0000 (18:40 +0300)]
Add cxgb4

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
8 years agoAdd libcxgb4 support
Vladimir Sokolovsky [Thu, 28 Jul 2011 15:30:22 +0000 (18:30 +0300)]
Add libcxgb4 support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
9 years agoinstall.pl: add 2.6.37 - 2.6.39 kernel.org support
Vladimir Sokolovsky [Wed, 22 Jun 2011 12:20:37 +0000 (15:20 +0300)]
install.pl: add 2.6.37 - 2.6.39 kernel.org support

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
9 years agoinstall.pl: Grant non root users read/write permission for umad devices instead of...
Vladimir Sokolovsky [Thu, 31 Mar 2011 16:07:00 +0000 (18:07 +0200)]
install.pl: Grant non root users read/write permission for umad devices instead of default

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
9 years agoDisable open-iscsi on RHEL6 vofed-1.5.3 vofed-1.5.3.1
Vladimir Sokolovsky [Wed, 23 Feb 2011 13:55:23 +0000 (15:55 +0200)]
Disable open-iscsi on RHEL6

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
9 years agolibsysfs-devel is not required by mvapich2 on RHEL5.x
Vladimir Sokolovsky [Mon, 21 Feb 2011 12:54:39 +0000 (14:54 +0200)]
libsysfs-devel is not required by mvapich2 on RHEL5.x

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
9 years agoAdd mpitests over mvapich2 and openmpi to the list of available packages
Vladimir Sokolovsky [Sun, 13 Feb 2011 08:04:54 +0000 (10:04 +0200)]
Add mpitests over mvapich2 and openmpi to the list of available packages

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
9 years agoinstall.pl: require depandencies for MPI with gcc
Vladimir Sokolovsky [Thu, 10 Feb 2011 08:38:24 +0000 (10:38 +0200)]
install.pl: require depandencies for MPI with gcc

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>
9 years agoinstall.pl: Fix Distro detection and dependencies
Vladimir Sokolovsky [Thu, 27 Jan 2011 10:03:02 +0000 (12:03 +0200)]
install.pl: Fix Distro detection and dependencies

Signed-off-by: Vladimir Sokolovsky <vlad@mellanox.co.il>